Report Lead Lists Not Available

Incident Report for Decision Cloud

Resolved

This incident has been resolved.
Posted Mar 11, 2026 - 15:57 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2026 - 15:36 PDT

Identified

On the reports page, lists of leads when clicking into a count may not be available for some users. We have identified the cause and are working on a fix.
Posted Mar 11, 2026 - 14:54 PDT
This incident affected: Decision Cloud - Web Site and Decision Cloud - Reports.