Application Delay
Incident Report for Decision Cloud
Resolved
This incident has been resolved.
Posted Nov 24, 2021 - 14:46 PST
Monitoring
An application delay has been identified and a fix has been implemented. We are monitoring performance now.
Posted Nov 24, 2021 - 08:18 PST
This incident affected: Decision Cloud - Web Site.