API Processing Impacted
Incident Report for Decision Cloud
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 08:12 PDT
Update
Ruleset and Price Reject Updates:
A patch has been applied fixing the issue with most rulesets, specifically those using Service Result in rules. We are keeping an eye out for other ruleset issues and have a patching methodology in place.

A fix was supposed to complete this morning before traffic. Unfortunately, the unrelated spike in processing time caused safeguards to trigger canceling the process.

We apologize that it did not complete for the early morning traffic.

All API services online and processing.
Posted Apr 23, 2024 - 08:12 PDT
Update
Server restart was conducted and metrics are returning to normal levels.

Leads Flowing normally at this time.
Posted Apr 23, 2024 - 06:21 PDT
Update
We are investigating a spike in processing times and high error rates.
Posted Apr 23, 2024 - 06:10 PDT
Update
Roughly 50% of the ruleset conditions have been fixed.

We have processes running through the night to continue fixing assorted ruleset conditions and will provide further updates in the AM.
Posted Apr 22, 2024 - 22:40 PDT
Identified
We have identified the cause of the issues with rulesets, specifically price reject, and are working toward a solution.
Posted Apr 22, 2024 - 04:40 PDT
Investigating
We are investigating impacts to API processing.

We have confirmed rulesets are impacted at this time and are looking into the situation further.
Posted Apr 22, 2024 - 03:26 PDT
This incident affected: Decision Cloud - API (Lead Processing).